webnsupdate/flake-modules/default.nix
Jalil David Salamé Messina 618670512e
All checks were successful
/ check (push) Successful in 1m22s
/ build (push) Successful in 2s
fix: overlay was broken T-T
2024-10-28 22:41:12 +01:00

32 lines
585 B
Nix

{ inputs, ... }:
{
imports = [
inputs.treefmt-nix.flakeModule
./package.nix
./module.nix
./tests.nix
];
perSystem =
{ pkgs, ... }:
{
# Setup formatters
treefmt = {
projectRootFile = "flake.nix";
programs = {
nixfmt.enable = true;
rustfmt.enable = true;
statix.enable = true;
typos.enable = true;
};
};
devShells.default = pkgs.mkShellNoCC {
packages = [
pkgs.cargo-insta
pkgs.cargo-udeps
pkgs.mold
];
};
};
}