Jalil David Salamé Messina
f2e8f59c6a
All checks were successful
/ check (push) Successful in 48s
/ build (audiomenu) (push) Successful in 2s
/ build (docs) (push) Successful in 2s
/ build (jpassmenu) (push) Successful in 2s
/ build (nixosConfigurations.vm.config.system.build.toplevel) (push) Successful in 2s
/ build (nvim) (push) Successful in 2s
This fixes the `nixos-option` build issues with the upgrade to 24.11
70 lines
2 KiB
Nix
70 lines
2 KiB
Nix
# This flake was initially generated by fh, the CLI for FlakeHub (version 0.1.9)
|
|
{
|
|
# A helpful description of your flake
|
|
description = "My NixOS configuration";
|
|
|
|
# Flake inputs
|
|
inputs = {
|
|
nixpkgs.url = "nixpkgs/nixos-24.11";
|
|
unstable.url = "nixpkgs/nixos-unstable";
|
|
# Lix
|
|
lix-module = {
|
|
url = "https://git.lix.systems/lix-project/nixos-module/archive/2.91.1-1.tar.gz";
|
|
inputs = {
|
|
nixpkgs.follows = "nixpkgs";
|
|
flake-utils.inputs.systems.follows = "systems";
|
|
};
|
|
};
|
|
# Modules
|
|
home-manager = {
|
|
url = "github:nix-community/home-manager/release-24.11";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
stylix = {
|
|
url = "github:danth/stylix"; # pin to release-24.11 once available
|
|
inputs = {
|
|
nixpkgs.follows = "nixpkgs";
|
|
flake-utils.follows = "lix-module/flake-utils";
|
|
systems.follows = "systems";
|
|
|
|
home-manager.follows = "home-manager";
|
|
# disable optional inputs
|
|
flake-compat.follows = "";
|
|
};
|
|
};
|
|
nixvim = {
|
|
url = "github:nix-community/nixvim";
|
|
inputs = {
|
|
nixpkgs.follows = "unstable";
|
|
home-manager.follows = "home-manager";
|
|
flake-parts.follows = "flake-parts";
|
|
treefmt-nix.follows = "treefmt-nix";
|
|
# disable optional inputs
|
|
flake-compat.follows = "";
|
|
nix-darwin.follows = "";
|
|
nuschtosSearch.follows = "";
|
|
devshell.follows = "";
|
|
git-hooks.follows = "";
|
|
};
|
|
};
|
|
flake-parts = {
|
|
url = "github:hercules-ci/flake-parts";
|
|
inputs.nixpkgs-lib.follows = "nixpkgs";
|
|
};
|
|
treefmt-nix = {
|
|
url = "github:numtide/treefmt-nix";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
# For deduplication
|
|
systems.url = "github:nix-systems/default";
|
|
};
|
|
|
|
# Flake outputs that other flakes can use
|
|
outputs =
|
|
inputs:
|
|
inputs.flake-parts.lib.mkFlake { inherit inputs; } {
|
|
systems = import inputs.systems;
|
|
|
|
imports = [ ./flake-modules ];
|
|
};
|
|
}
|