configuration.nix/flake-modules/default.nix
Jalil David Salamé Messina 002c74ca1b
All checks were successful
/ check (push) Successful in 24s
/ build (audiomenu) (push) Successful in 2s
/ build (docs) (push) Successful in 2s
/ build (jpassmenu) (push) Successful in 2s
/ build (nixosConfigurations.vm.config.system.build.toplevel) (push) Successful in 2s
/ build (nvim) (push) Successful in 2s
feat(flake): switch to treefmt-nix
This allows me to remove all checks and replace them with treefmt-nix
2024-10-15 22:21:36 +02:00

34 lines
649 B
Nix

{ inputs, ... }:
let
overlays = builtins.attrValues inputs.self.overlays;
in
{
imports = [
inputs.treefmt-nix.flakeModule
./devshells.nix
./docs.nix
./example-vm.nix
./nixos-modules.nix
./nvim.nix
./overlays.nix
./scripts.nix
];
perSystem =
{ system, ... }:
{
_module.args.pkgs = import inputs.nixpkgs { inherit system overlays; };
# Setup formatters
treefmt = {
projectRootFile = "flake.nix";
programs = {
nixfmt.enable = true;
rustfmt.enable = true;
statix.enable = true;
typos.enable = true;
};
};
};
}